Error when attempting to Start a remote system

Mar 23, 2009 at 12:15 AM
I installed the Full setup on a machine running win2k3. I configured the service with the default values for the service and the service started normally. I verified that the proxy machine is in fact listening on port 8731. On the client machine I did just the client install. I specified for the proxy http://ip.of.proxy.machine:8731/DeSleeper/  . I Then attempted to start a target machine. I get an error that says the following. 

There was no endpoint listening at http://ip.of.proxy.machine:8731/DeSleeper/  that could accept the message. This is often caused by an incorrect address or SOAP action. See inner expection if present for more details.

I get the same behavior on the proxy machine if I have it use itself as the proxy.

I have verified from my firewall logs that a tcp packet on port 8731 does in fact go to the proxy machine. Any ideas on what I might be doing wrong? 

Thanks, this will be great if I get it working.

--mike
Mar 23, 2009 at 12:39 AM
When sniffing the internal port of my firewall I see the following message returned from the proxy machine

HTTP/1.1 400 Bad Request..Content-Type: text/html..Date: Mon, 23 Mar 2009 00:31:28 GMT..Connection: close..Content-Length:39....<h1>Bad Request(InvalidHostname)</h1>

If that helps at all

--mike
Coordinator
Mar 24, 2009 at 4:30 AM
Which method are you using to try the wake-up?  Via host-name?  You might try via MAC Address and see if your results are different.  One gotcha which I'm still working on is that the very very first time you wake up a machine via host name you need to have the system on.  That sounds weird, but what the service needs to cache the HostName/Mac Address association, which is, on most networks, not something that can be done while the machine is off.  So the solution is to pre-cache the association by sending one wakeup request while the target is on.

What I think I will do in a not too distant future version, is to have a place on the service installation tab to enter in the names of machines you want to be able to wakeup, and this will precache.  Hopefully more intuitive than the first option..  Also, your question has helped me find an error message bug.. if I understand your problem it really should have said "Unregistered host, wake up failed.", but I missed something and you got the InvalidHostName instead... I know, not especially helpful either, but at least it doesn't make you think your firewall or such is suspect.


Mar 25, 2009 at 3:47 PM
I am using mac address, in fact without the requirement you note, I wouldn't have thought it possible to do via hostname or ip. However, as you explain, you maintain your own little arp table for DeSleeper to refer to. I can wake up the machine in question when I use a regular WOL on the local subnet, so I know I have everything else set up correctly.

If there are logs or traces you need, just let me know.

Coordinator
Mar 27, 2009 at 1:49 AM
You might try the new version I posted last night.  I fixed some of the issues I mentioned above, maybe yours is one of them, though what you say makes me think otherwise.
Mar 28, 2009 at 12:52 PM
I'll give it a try. I have since gotten WOL working without a proxy working through my vpn but I will continue testing it so you can get the feedback on whatever the issue is, that is if any issue remains after I test the new version.
Mar 29, 2009 at 7:14 PM
I installed beta 1-11 on both ends. Same result, same error message. Wish I could tell you more.
Coordinator
Mar 30, 2009 at 7:18 AM
Well, does tell me something.  If it was what I initially thought the error message would have changed.  I'm starting to suspect the possibility there is another HTTP server taking control of that port.. though that seems improbable I may as well ask.

There should be a file called DeSleeperService.log but unfortunately it ends up in different places depending on whether it's Vista/XP.  I'll try to get you details on where to find it tomorrow.
Mar 30, 2009 at 11:06 AM
There is a webserver on a relatively nearby port....a wsus (Windows Update) server on port 8530, but nothing on port 8730. I did a search for DeSleeperService.log  but did not find any matches. Also, if it matters, as I mentioned in my original post, platform is win2k3.